Youtube comments not loading

Just switched from Chrome to Firefox and set up the about:config tweaks and everything is working well. However, on Youtube the comment section won’t load, it just shows a circle spinning. Any suggestions as to a fix?

Thanks

can you see the messages in console log? this problem is first time i face so bear with me lets try solve it (even if my words sound dumb :joy:) so first try more than video if you still face problem then open dev console and tell me errors you get

No it doesn’t sound dumb, I am sort of a new user. I am going to try and give you what you need.

There are 2 errors from the Web Console Ctrl Shift K:

  1. Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://googleads.g.doubleclick.net/pagead/id. (Reason: CORS request did not succeed).
  2. The loading of “https://accounts.google.com/ServiceLogin?continue=https%3A%2…passive%26hl%3Den&passive=true&service=youtube&uilel=3&hl=en” in a frame is denied by “X-Frame-Options“ directive set to “DENY“.

Thank you in first :joy:

first one i guess its related to block ads so its fine.
second one if i get it right, it blocks frame (like that photo frame, part of site in another site) and it blocks the part that related to google accounts (i do not know why) so try this addon and tell me: https://addons.mozilla.org/en-US/firefox/addon/ignore-x-frame-options-header/ (if this worked that means google uses frames and this is weird from google)

With the extension the comments still don’t load and it looks like only the first error occurred.

yes first error it means it blocked the ads domain of google. at least that means the addon fixed the problem but seems not related to yt comments one :joy:. this is really weird and never got something like this error before — so you can uninstall addon then seems its useless and i have some thoughts about media.gmp-widevinecdm.enabled so try switch it back to true and tell (if it did not work you gotta wait on me more time to see another way :joy: )


actually if you can, make more 2 firefox profiles one with addons u use and other with tweaks and test ? and tell me results

Tried to switch media.gmp-widevinecdm.enabled to true and the comments still aren’t loading.

I restarted firefox in safe mode with add-ons disabled and the problem still persists.

Next I am going to create the profiles and go from there, but it looks like it may be the tweaks.

Both profiles created and the comments load on both.

so commends loads on the addons only profile and loads too on the tweaks only profile? that is weird as frick :joy:. im right ? you mean the commends load on both ?

yep, comments load on both.

And on a side note, if a site is not working due to one of the config tweaks is there a way to whitelist a website?

nope. and this is weird :joy: i mean if it was not on addons side as example i would say addons problem and same on tweaks profile but works on both this is weird :joy: i mean it should work fine then okay did u added tweaks in addon as u did in ur main profile ?

No, I kept both profiles separate.

no i mean in addons profile, did you added the tweaks or made addons default ?

For the addons profile its the default and only the addons and no tweaks.

okay good note, in your main profile the firefox profile you tweaked the addons i mean you changed its settings or still the defaults too ?

Right, some of the addon settings have been changed in the main profile in addition to the tweaks.

well, maybe we got the problem :V, now i want you copy those settings to your addon profile and tell me results (lets hope my theory right because after it i would be out of ideas :joy:)

I don’t see the settings!

what you mean? i want from you go to addons profile (that firefox profile you created for addons) and add same settings you added in your main firefox profile. if comments does not load then we finally spotted the problem and its in ur addons so we will need to see those settings and check them, if problem still then you might give me some time to get more ideas to troubleshoot this problem :joy:

Okay, I added the tweaks to the Addon profile and the comments are loading. Also, I am having trouble playing movie sites on both profiles. This problem seems like a firefox problem, but I am not sure.