Tried to install standard Firefox (non-ESR), but can't create a desktop launcher

I realized that the Firefox version that comes pre-installed with Debian 10 is the ESR and not the regular one, so I wanted to get it in order to get the newest features. I followed this video(https://invidio.us/watch?v=8IhGh-lchug) and used this wiki(https://wiki.learnlinux.tv/index.php/Installing_non-ESR_Firefox_in_Debian_10) alongside. I followed every step, but when I finish there’s no launcher that I can find, the only way for me to use it, is by going to ~/opt/firefox/firefox and clicking the executable.

Did I do something wrong?

Here’s the directory where my main firefox folder is located: ~/opt/firefox/firefox
Here’s the directory where my .desktop is located: ~/usr/share/applications/firefox-custom.desktop

This is what’s inside of my firefox-custom.desktop:

[Desktop Entry]
Version=1.0
Name=Firefox Web Browser
Comment=Browse the World Wide Web
GenericName=Web Browser
Keywords=Internet;WWW;Browser;Web;Explorer
Exec=/opt/firefox/firefox %u
Terminal=false
X-MultipleArgs=false
Type=Application
Icon=firefox
Categories=GNOME;GTK;Network;WebBrowser;
MimeType=text/html;text/xml;application/xhtml+xml;application/xml;application/rss+xml;application/rdf+xml;image/gif;image/jpeg;image/png;x-scheme-handler/http;x-scheme-handler/https;x-scheme-handler/ftp;x-scheme-handler /chrome;video/webm;application/x-xpinstall;
StartupNotify=true
Actions=new-window;new-private-window;

[Desktop Action new-window]
Name=Open a New Window
Exec=/opt/firefox/firefox -new-window

[Desktop Action new-private-window]
Name=Open a New Private Window
Exec=/opt/firefox/firefox -private-window

Any ideas?

I think your desktop entry should be in ~/.local/share/applications/, I haven’t heard of ~/usr before.

Below the line is the long comment I wrote before spotting this issue.


Which desktop environment do you use? Have you tried to log out and log back in, in case your environment requires that?

I didn’t check your links, but what I generally do is

  1. download the package and signature
  2. verify the signature
  3. extracting it to ~/.local/firefox
  4. starting it once and selecting that I do want it as my default browser and it creates ~/.local/share/userapp-Firefox-??????.desktop
  5. which I then edit and change NoDisplay=true to NoDisplay=false and also edit the name a bit so I recognise it.
  6. it just appears on dmenu when I press Windows + D (I use i3).

In case it helps, here is my userapp-Firefox-S7E8E0.desktop (the string seems random)

[Desktop Entry]
Encoding=UTF-8
Version=1.0
Type=Application
NoDisplay=false
Exec=/home/mikaela/.local/firefox/firefox-bin %u
Name=01 Firefox Stable
Comment=Oma määrittely kohteelle Firefox

Here’s an extract from the wiki, basically my directory works to be available to all users and yours just to the current one:

Save it in one of the following locations depending on if you’d like it to be available everyone or just yourself

Global: /usr/share/applications/firefox-custom.desktop

Local: ~/.local/share/applications/firefox-custom.desktop

I use Gnome, I have reboot it and also turn off and on.

I selected it as my default browser but it didn’t created anything. Maybe I have to move it both to “/usr/share/applications/firefox-custom.desktop” and “~/.local/share/applications/firefox-custom.desktop”?

What’s this for?

Oh, your tildes confused me. I searched a bit more now, and this looks promising:

sudo apt install desktop-file-utils # contains the command update-desktop-database
hash -r # refreshes installed binaries
sudo update-desktop-database # should update app menus based on the content of the
# applications directories

Afterwards I guess alt+f2 and executing r to restart gnome-shell should make sure that if it works, gnome will notice it.


NoDisplay=true would hide it from all app menus and Firefox seems to do that by default.

Everything goes well until here:

user@debian:~$ sudo update-desktop-database
Error in file “/usr/share/applications/firefox-custom.desktop”: “x-scheme-handler /chrome” is an invalid MIME type ("x-scheme-handler " a media type that contains an invalid character)

Could it be because of that space?

I think so

I removed the space from that, and I did alt+f2 and run sudo r but nothing happened when I searched for Firefox on my apps. Fuuuuuuuuuuuck.

Did you try just r without sudo? Sudo has the password prompt and I imagine r would be an unknown command as it’s GNOME inbuild as far as I know of, so nothing happening with sudo r doesn’t terribly surprise me.

I tried and it says “restart is not available on Wayland”, but sudo r it doesn’t say anything.

I guess in that case you need to log out and log back in

I tried it yesterday and tried it today after having turn off my machine, still not works.

from what is saw that your problem in desktop shortcut so try this:

[Desktop Entry]
Version = 1.0 #change version (its not important and maybe remove me)
Type = Application
Terminal = false
Name = Feem #change name (and maybe remove me)
Exec = /opt/feem/feem.AppImage #change where it execute (and maybe remove me)
Icon = /opt/feem/feem.png #change icon (and maybe remove me)
Categories = Application; #change categories (its not important and maybe remove me)

i not need to tell you that save it inside usr -> share -> applications also under firefox.desktop name

I’m going to try this first and then I’ll try what you said. Thanks BTW!