Signal notifications without Google Services?

In GitHub @blacklight447 says that Signal hasn’t needed Google Services for years in these two comments:

@blacklight447 Can you tell me more about your setup? What OS are you running, are you sure it doesn’t have any traces of Google Services?

I have a problem that some of the closest people to me say that they cannot get Signal notifications for not having play services (and another uses iOS and doesn’t XMPP clients with notifications) and I am wondering if they are doing something wrong, is there an setting they have missed or can anyone offer other advice?

Signal works for me without Google Play Services. It runs a background service (that keeps a notification always on). Make sure it can display that notification, and battery optimization for the app is disabled.

The other possibility is that the version of Signal from Google Play does indeed require Google Play Services. I have no idea, I’ve never used it. Make sure you are using the APK version from https://signal.org/android/apk/#apk-danger.

This works for me on a Pixel 3 with GrapheneOS, which is the same setup as blacklight (although maybe he has a 3a).

I have uninstalled G services and I the only way I can get notifications from Signal is if I enter the app, battery optimization is disabled and I don’t use the GPstore version. Also, you need the latest version of GPstore to create an account.

1 Like

I just tested it:

  1. Downloaded Signal APK from link above.
  2. Installed, entered phone number
  3. Received notification about “Missing Google Play Services” – Here, it specifically says you can still use Signal regardless.
  4. Clicked “I Understand”
  5. Verified code via SMS
  6. Created profile
  7. Created PIN
  8. Dismissed banner to make default SMS app
  9. Closed app, re-opened app, closed app again

And after closing the app that time, I received a “Signal: Background connection enabled” notification (which is what I was looking for) that can’t be dismissed. At this point I could receive notifications without the app open.

I just tested this entire configuration with a spare phone number on a spare Android phone with a new Signal installation. Pixel 3, GrapheneOS (Android 10).

I just tried and it works, but I don’t get the same error than before, I didn’t get “Missing GPservices” but something along the lines of “You need to update G services to the last version to use Signal”. I tried this on two phones without G services and it didn’t work one or two months ago.

Are you sure you don’t have Google Play Services, but it’s just disabled? Or, are you using a custom ROM that has never had Google Play installed at all?

I “disabled” them, but when I do so it says “uninstalling” so I don’t know exactly, still, I don’t see why that would be an issue before but not now.
I am using some version of Android 5.1 that comes with a Samsung Galaxy something.

If you have Google Play Services installed it will detect that and try and use it and give you a warning, even if it is disabled. I doubt the Signal APK will work for you in that case.

1 Like

Thanks @jonah, it turns out that my problem user has Play Services in a broken state in their firmware and they cannot get properly rid of it so no Signal for us :crying_cat_face:

1 Like